DROP IMAGE REPOSITORY

DROP IMAGE REPOSITORY

현재/지정된 스키마에서 지정한 이미지 저장소(Image Repository)를 제거하는 명령어입니다.

출처: 문서

본문

DROP IMAGE REPOSITORY는 현재/지정된 스키마에서 지정한 이미지 저장소를 제거합니다. 관련 명령어로 CREATE IMAGE REPOSITORY, SHOW IMAGE REPOSITORIES가 있어요.

구문 (Syntax)

DROP IMAGE REPOSITORY [ IF EXISTS ] <name>

파라미터 (Parameters)

  • name — 삭제할 저장소의 식별자를 지정합니다.

접근 제어 요구 사항 (Access control requirements)

이 작업을 실행하는 역할은 최소한 OWNERSHIP 권한(객체: Image repository)이 있어야 합니다.

스키마 안의 객체를 조작하려면 상위 데이터베이스에 대한 권한이 1개 이상, 상위 스키마에 대한 권한이 1개 이상 필요합니다. 지정된 권한 집합으로 커스텀 역할을 만드는 방법은 Creating custom roles을, securable 객체에 대한 역할과 권한 부여에 관한 일반 정보는 Overview of Access Control을 참고하세요.

사용 참고 사항 (Usage notes)

  • 그 저장소의 이미지를 참조하는 서비스가 실행 중인 동안 이미지 저장소를 삭제하면 문제가 발생할 수 있습니다. 현재 실행 중인 서비스 인스턴스와 잡은 계속 실행되지만, 새 서비스 인스턴스를 만들려는 모든 시도는 실패합니다.
  • IF EXISTS 절을 지정하고 대상 객체가 존재하지 않으면, 명령어는 오류를 반환하지 않고 성공적으로 완료됩니다.

예제 (Examples)

다음은 tutorial_repository라는 저장소를 삭제하는 예제입니다.

DROP IMAGE REPOSITORY tutorial_repository;
+-------------------------------------------+
| status                                    |
|-------------------------------------------|
| TUTORIAL_REPOSITORY successfully dropped. |
+-------------------------------------------+

더 알아보기 (Learn more)