본문 바로가기
WIKI 기술 지식 베이스

PostgreSQL 15 이상으로 업그레이드하기

원문 보기 위키 갱신

이 페이지에서는 PostgreSQL 15 이상으로 업그레이드할 때 datadog 사용자에게 필요한 추가 권한을 활성화하는 방법과, 버전에 따라 발생할 수 있는 연결 관련 설정을 다뤄요.

출처: 문서

본문

각 데이터베이스 호스트에서 아래 명령을 실행해서 datadog 사용자에게 필요한 추가 권한을 활성화하세요:

ALTER ROLE datadog INHERIT;

RDS

7.49 이전 버전의 에이전트는 설정 변경 없이는 PostgreSQL RDS 인스턴스에 연결하지 못할 수 있어요. 신규 RDS 인스턴스는 rds.force_ssl 파라미터의 기본값이 1이에요. 7.49 이전 버전의 에이전트에서 이로 인해 에이전트가 쿼리를 실행하려 할 때 다음 오류가 발생해요:

FATAL:  no pg_hba.conf entry for host "HOSTNAME", user "datadog", database "postgres", no encryption

에이전트가 SSL로 연결할 수 있게 하려면 host와 port가 지정된 각 인스턴스 설정에 아래 설정을 추가하세요:

ssl: allow

이 변경을 적용한 후 에이전트를 재시작하세요.

Google Cloud SQL

7.50 이전 버전의 에이전트는 cloudsqladmin 데이터베이스에 연결을 시도할 수 있어요. 이로 인해 데이터베이스에 오류 로그와 에이전트의 경고 로그가 발생할 수 있어요. 이런 로그를 조용히 만들려면 ignore_databases 목록에 cloudsqladmin을 추가하세요:

ignore_databases:
  - template%
  - rdsadmin
  - azure_maintenance
  - cloudsqladmin

데이터베이스 자동탐지(database autodiscovery)를 사용한다면 제외 데이터베이스(excluded databases)에도 cloudsqladmin을 추가하세요:

  exclude:
   - cloudsqladmin

더 알아보기 (Learn more)