노마드 엔터프라이즈 라이선스 FAQ
노마드 엔터프라이즈 라이선스 FAQ
이 FAQ는 Nomad Enterprise v1.6.0+ent에서 도입된 라이선스 변경에 대한 것이에요.
이전 버전의 라이선스 관련 FAQ는 이 페이지의 버전 드롭다운(예: v1.5.x)에서 이 문서의 이전 버전을 참고해 주세요.
출처: 문서
본문
Q: 노마드 변경사항에 대한 빠른 요약을 얻을 수 있나요?
Nomad Enterprise v1.6.0부터 라이선스 만료가 달라져요.
평가판 라이선스의 경우 동작은 동일해요. 라이선스가 만료되면 엔터프라이즈 기능이 중지되며, 만료된 라이선스로는 서버가 시작될 수 없어요.
새로운 "비종료(non-terminating)" 계약 라이선스의 경우, 만료를 현재 시간과 비교하는 대신 만료 시간을 nomad version 명령 출력에서 찾을 수 있는 노마드 바이너리의 빌드 날짜와 비교해요.
실질적인 결과는, 더 새로운 계약 라이선스가 라이선스 만료 시간 이전에 빌드된 모든 v1.6.0+ 노마드 버전에 대해 영구히 동작한다는 거예요. 어떤 기능도 중지되지 않으며 서버 에이전트를 안전하게 다시 시작할 수 있어요.
하지만 라이선스 만료 이후의 더 새로운 바이너리로 업그레이드하려 하면 서버가 시작되지 않아요. 이를 선제적으로 피하려면 서버 업그레이드를 시도하기 전에 새 nomad license inspect 명령으로 라이선스를 사용해 새 바이너리를 테스트할 수 있어요.
Q: 어떤 리소스가 사용 가능한가요?
아래 목록은 일반적인 라이선스 사용에 대해 더 배우기 좋은 출발점이에요.
- v1.6.0 Upgrade Guide
- Nomad License Documentation
- License configuration values documentation
- Install a HashiCorp Enterprise License Tutorial
Q: 이것이 노마드의 이전 버전에 영향을 주나요?
이 변경은 Nomad Enterprise v1.6.0+ent 이상 버전에만 영향을 줘요.
Q: 라이선스가 노마드 클라이언트 노드에 있어야 하나요?
라이선스가 있어야 하는 것은 노마드 서버 노드뿐이에요. -dev 플래그로 실행되는 노마드 에이전트도 라이선스가 필요해요.
Q: 라이선스 변경 때문에 업그레이드 중에 겪을 수 있는 함정은 무엇인가요?
아직 완전히 비기능 상태가 되지 않은 만료 라이선스(즉 ExpirationTime과 TerminationTime 사이의 유예 기간에 있는 경우)가 있다면, 노마드 서버는 새 v1.6.0+ 바이너리로 시작할 수 없어요.
서버 에이전트를 종료해 새 버전으로 교체하기 전에 반드시 새 바이너리로 nomad license inspect를 실행해 주세요.
Q: 사용자가 기존 라이선스를 어떻게 얻을 수 있나요?
기존 HashiCorp 엔터프라이즈 고객이라면 조직의 고객 성공 관리자(CSM)에게 문의하거나 [email protected]에 이메일을 보내 조직의 엔터프라이즈 라이선스를 얻는 방법에 대한 정보를 받을 수 있어요. nomad license get으로 라이선스 자체가 아닌 라이선스에 대한 정보를 검색할 수 있어요.
Q: 라이선스가 만료되면 어떻게 되나요?
라이선스 만료 시간보다 더 새로운 노마드로 업그레이드하려 시도할 때까지 모든 기능은 계속 동작해요. 그 경우 서버 에이전트가 시작에 실패하며, 이전 작동 버전으로 롤백하고 업그레이드를 다시 시도하기 전에 더 새로운 노마드 버전과 함께 사용할 새 라이선스를 확보해야 해요.
Q: 라이선스는 클러스터별 또는 노드별입니까?
라이선스는 다른 노드와 다른 클러스터에서 재사용할 수 있어요.
Q: 사용자는 노마드 평가판 라이선스를 어디서 얻을 수 있나요?
이 지침에 따라 무료 30일 평가판 라이선스를 요청하고 활성화해 주세요.
Q: 노마드 클라이언트 에이전트가 다시 시작되면 여전히 라이선스 파일이 필요하나요?
nomad agent가 서버로 실행될 때마다(또는 -dev에서) 라이선스가 필요해요.
Q: 노마드 엔터프라이즈를 v1.6.0에서 이전 버전으로 다운그레이드할 수 있나요?
네. 서버를 1.6.0+로 업그레이드했지만 라이선스 만료 때문에 시작에 실패하면, 이전 만료 로직을 사용하는 이전 작동 버전으로 롤백할 수 있어요.
라이선스 만료 외의 다른 이유로 서버 시작이 실패하면, 노마드 상태 저장소에 전방 호환성이 없어 이전 버전으로의 롤백은 지원되지 않으며 크래시 루프가 발생할 수 있어요.
Q: 라이선스 구성 단계에 사용 가능한 튜토리얼이 있나요?
Enterprise License Tutorial을 방문해 주세요.