EC2Launch v2 버전 기록
EC2Launch v2 버전 기록
최신 시작 에이전트가 설치되어 있는지 확인하려면 Install the latest version of EC2Launch v2를 참고하세요. EC2Launch v2 에이전트의 새 버전이 출시될 때 알림을 받을 수 있어요. 자세한 내용은 Subscribe to EC2 Windows launch agent notifications를 참고하세요.
출처: 문서
본문
다음 표는 출시된 EC2Launch v2 버전을 설명합니다.
버전 기록
| 버전 | 상세 | 출시일 |
|---|---|---|
| 2.5.2 | 2026년 8월 5일 | |
| 2.5.1 | 2026년 6월 3일 | |
| 2.5.0 | 2026년 5월 4일 | |
| 2.4.0 | 2026년 3월 5일 | |
| 2.3.237 | 2026년 2월 25일 | |
| 2.3.108 | 2025년 12월 29일 | |
| 2.3.56 | 2025년 11월 4일 | |
| 2.3.5 | 2025년 9월 15일 | |
| 2.2.63 | 2025년 7월 29일 | |
| 2.1.1 | 2025년 5월 14일 | |
| 2.0.2107 | 2025년 3월 27일 | |
| 2.0.2081 | 2025년 2월 4일 | |
| 2.0.2046 | 2024년 10월 3일 | |
| 2.0.1981 | 2024년 8월 6일 | |
| 2.0.1948 | 2024년 7월 1일 | |
| 2.0.1924 | 2024년 6월 10일 | |
| 2.0.1914 | 2024년 6월 5일 | |
| 2.0.1881 | 2024년 5월 8일 | |
| 2.0.1815 | 2024년 3월 6일 | |
| 2.0.1739 | 2024년 1월 17일 | |
| 2.0.1702 | 2024년 1월 4일 | |
| 2.0.1643 | 2023년 10월 4일 | |
| 2.0.1580 | 2023년 9월 5일 | |
| 2.0.1521 | 2023년 7월 3일 | |
| 2.0.1303 | 2023년 5월 3일 | |
| 2.0.1245 | 2023년 3월 8일 | |
| 2.0.1173 | 2023년 2월 6일 | |
| 2.0.1121 | 2023년 1월 4일 | |
| 2.0.1082 | 2022년 12월 7일 | |
| 2.0.1011 | 2022년 11월 11일 | |
| 2.0.1009 | 2022년 11월 8일 | |
| 2.0.982 | 2022년 10월 31일 | |
| 2.0.863 | 2022년 7월 6일 | |
| 2.0.698 | 2022년 1월 30일 | |
| 2.0.674 | 2021년 11월 15일 | |
| 2.0.651 | 2021년 10월 7일 | |
| 2.0.592 | 2021년 8월 31일 | |
| 2.0.548 | 2021년 8월 4일 | |
| 2.0.470 | 2021년 7월 20일 | |
| 2.0.285 | 2021년 3월 8일 | |
| 2.0.207 | 2021년 2월 2일 | |
| 2.0.160 | 2020년 12월 4일 | |
| 2.0.153 | UserData에 Sysprep 기능 추가 | 2020년 11월 3일 |
| 2.0.146 | 2020년 10월 6일 | |
| 2.0.124 | 2020년 9월 10일 | |
| 2.0.104 | 2020년 8월 12일 | |
| 2.0.0 | 최초 릴리스 | 2020년 6월 30일 |
주요 변경 사항
2.5.x
- 사용자 지정 인증서와 Group Policy로 배포된 인증서에 대해 RDP 인증서 검증이 실패하는 문제 수정.
- 최대 절전 활성화 시 오류 감지 개선.
- 직렬 포트를 사용할 수 없을 때 에이전트 작업을 계속하도록 직렬 포트 로직 업데이트.
- 인스턴스 콘솔 출력에 EC2 Windows Utility Device 드라이버 버전 추가.
- 사용하지 않는 bench.log 파일 제거.
- 인스턴스 콘솔 출력 기록 시 드라이버 조회 최적화.
- 중복된 console.log, err.log 파일을 제거해 에이전트 로깅 단순화.
- 로그 순환 추가, 로그 크기를 1MB로 제한하고 시간 정밀도를 밀리초로 개선해 에이전트 로깅 기능 향상.
- Hyper-V 상태 조회 및 관련 인스턴스 콘솔 출력 제거.
2.4.0
- 특정 Visual C++ 런타임 버전과 에이전트 원격측정(telemetry) 함수의 비호환성으로 인한 에이전트 크래시 문제 수정.
2.3.237
- 배경화면에 IPv6 주소 표시 추가. Memory 및 Network 속성은 AWS Documentation 참고.
2.3.108
- 사전 구성된 영구 네트워크 라우트가 EC2Launch v2에서 제대로 처리되지 않는 문제 수정.
- 라우트 추가 시 IMDS를 사용한 기본 네트워크 인터페이스 감지 개선.
2.3.56
- Telemetry 개선을 위해 시작 에이전트 업데이트.
- IPv6 완전 지원 추가.
- 인터페이스에서 IPv4 또는 IPv6 주소를 사용할 수 없는 시나리오를 처리하도록 라우트 추가 기능 강화.
- RDP 인증서 정보가 제대로 검색·검증되지 않는 문제 수정. 필요 시 Remote Desktop Services를 자동으로 시작하는 기능 추가.
- 서비스 상태 조회 시 발생하는 문제를 수정하도록 EC2Launch v2 서비스 권한 조정.
2.3.5
- agent-config.yml 파일의 배경화면 경로를 기본 운영체제 배경화면 경로로 업데이트.
- 에이전트 오류가 발생한 위치를 모니터링하는 telemetry 추가.
- 에이전트 로그 메시지 업데이트.
2.2.63
- 비관리자 사용자를 위한 EC2Launch.exe CLI 명령 오류 메시지 업데이트.
- 관리자 암호 옵션 사용을 모니터링하는 telemetry 추가.
- EC2Launch 권한 수정.
2.1.1
- EC2Launch Settings UI 업데이트.
- 배경화면 CLI 명령 업데이트.
- EC2Launch 설치 프로그램 업데이트.
2.0.2107 / 2.0.2081
- 지정되지 않은 게이트웨이 주소(IPv4용 0.0.0.0 또는 IPv6용 ::)로 라우트 추가.
- IPv4와 IPv6 라우트를 항상 모두 추가.
- 지정하지 않았을 때 agent-config.yml 파일에 Administrator 사용자 이름이 추가되는 문제 수정.
- EC2Launch v2 권한 수정.
2.0.2046
- setAdminAccount 작업에 암호화된 암호 옵션 추가.
- agent-config.yml의 정적 암호를 암호화하는 CLI 명령 추가.
- XML user data가 Administrator 권한으로 실행될 때 PowerShell 인수가 추가되지 않는 문제 수정(자세한 내용은 How Amazon EC2 handles user data for Windows instances 참고).
- LocalSystem 권한으로 실행될 때 executeScript 작업과 user data 스크립트의 PowerShell 인수 조정. 인수가 비어 있으면 에이전트는 다음 기본값을 사용:
-ExecutionPolicy Unrestricted. - 콘솔 로그에 중복 드라이버 버전이 인쇄되지 않도록 방지.
2.0.1981
- sysprep 전 중요한 설정 실패 시 오류 처리를 조정해 실패하도록 함.
- 기본 네트워크 인터페이스에 여러 IP 주소가 할당된 인스턴스에서 배경화면·호스트 이름 작업이 잘못된 IP 주소를 사용하는 문제 수정.
- 배경화면·호스트 이름 작업이 IMDS에서 프라이빗 IP를 먼저 얻고, IMDS가 비활성화되면 WMI로 대체하도록 변경.
- transient 오류로 sc1 볼륨이 초기화에 실패하는 initializeVolume 작업 문제 수정.
2.0.1948
- Windows Administrator 사용자로 실행된 executeScript 작업이 종료 코드를 캡처하지 못하는 문제 수정.
2.0.1924 / 2.0.1914
- 표준 사용자에게 Telemetry.log 권한을 읽기·실행으로 제한.
- 시작 실패 시 EC2Launch Windows 서비스가 재시작되도록 구성.
- route.exe stderr 출력을 로깅해 add-routes 실패를 해결 가능하게 함.
- 라우트 메트릭이 범위 [1, 9999] 밖일 때 발생하는 문제 수정.
- 여러 새 인스턴스 유형에 배경화면 지원 추가.
- Windows Administrator 사용자로 실행되어 stderr로 출력을 보내는 user data 스크립트로 인한 문제 수정.
2.0.1881
- ebsnvme-id.exe 도구를 버전 1.1.0.7로 업데이트.
metal-*로 시작하는(예: metal-48x1) 메탈 인스턴스 유형에서 RSS(receive side scaling) 및 수신 대기열 깊이 설정 관련 문제 수정.- 에이전트를 차단하는 XML userdata 명령을 보고하는 telemetry 이벤트 제거.
- 레지스트리 항목
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Dnscache\Parameters\DomainNameDevolutionLevel에 따라 devolution을 제한하도록 setDnsSuffix 작업 업데이트. - 네트워크 라우트를 추가하는 공개 작업과 CLI 추가.
- Note – Windows Server 2012를 공식 지원하는 마지막 버전.
- Note – 32비트 운영체제를 공식 지원하는 마지막 버전.
2.0.1815
- 로그 파일 권한을 수정할 때 시작 에이전트가 오류를 처리하는 방식 변경.
- 직렬 포트 연결 시간 초과 추가. 이 시간 초과는 직렬 포트가 사용 중이어도 시작 에이전트가 계속 실행되게 합니다.
2.0.1739
- 에이전트 로그 메시지 업데이트.
- 에이전트 로그에서 executeScript 내용과 출력 제거.
- 에이전트 로그에서 executeProgram 인수와 출력 제거.
2.0.1702
- 콘솔 로그에 EnableSCSIPersistentReservations 값 추가.
2.0.1643
- 네트워크 라우트 추가 시 추가 오류 처리와 로그 줄 추가.
- PreReady 단계에서 executeScript와 executeProgram 작업 허용.
- executeScript 작업의 출력과 유사한 출력 파일을 생성하도록 executeProgram 작업 업데이트(자세한 내용은 executeProgram 참고).
- XML user data에서 에이전트를 차단하는 명령 사용을 모니터링하는 telemetry 추가.
2.0.1580
- 크래시 콜 스택을 명확한 텍스트로 로깅해 크래시 가시성 개선.
- Amazon EC2Launch 서비스가 EventLog 서비스보다 빨리 시작될 때 발생하는 크래시를 수정하기 위해 EventLog 서비스를 시작 종속성으로 추가.
- XML user data가 에이전트 구성 파일의 PreReady 단계보다 먼저 실행되도록 변경(EC2Launch v1 및 EC2Config와 동일).
- YAML user data 버전 1.1 추가해 user data가 에이전트 구성 파일의 PreReady 단계보다 먼저 실행되게 함(YAML user data 버전 1.0은 에이전트 구성 파일의 PostReady 단계 후 실행).
2.0.1521
- 배경화면에 인스턴스 태그를 표시하는 선택적 기능 추가(자세한 내용은 setWallpaper 참고).
- Elastic Graphics 보안 그룹이 제대로 설정되지 않았을 때 오류 처리 추가.
- Instance Metadata Service가 비활성화되었을 때 시간 초과 수정.
2.0.1303
- 퍼블릭 IPv4 주소가 할당되지 않았을 때 배경화면에 404 오류가 인쇄되는 문제 수정.
- 디바이스의 드라이브 문자가 D로 설정될 때 볼륨의 파일 시스템이 NTFS 대신 RAW로 포맷되는 문제 수정.
- NVMe SSD 볼륨이 EBS 볼륨으로 잘못 식별되는 문제 수정.
- IMDS가 비활성화되었을 때 Windows 활성화 오류 수정.
2.0.1245
- IMDS가 비활성화되었을 때 setWallpaper의 privateIpAddress 필드가 비어 있는 문제 수정.
- IMDS가 비활성화되었을 때 호스트 이름을 프라이빗 IPv4 주소로 설정하는 문제 수정.
- Windows Server 2012에서 볼륨 초기화 문제 수정.
- 점보 프레임 설정 문제 수정.
- 인스턴스 시작 시 SSH 키가 지정되지 않았을 때 오류 수정.
- Windows에 'ReleaseId' 레지스트리 키가 없을 때 Windows Server 2012의 오류 수정.
2.0.1173
- PnPDeviceID가 비어 있을 때 네트워크 어댑터를 찾는 로직 수정.
- 콘솔 포트 선택에 PCI 세그먼트 정보 사용.
2.0.1121
- RDP 정보를 얻는 재시도 로직 추가.
- d2.8xlarge 인스턴스의 볼륨 초기화 오류 수정.
- 재부팅 후 잘못된 네트워크 어댑터가 선택될 수 있는 문제 수정.
- ACPI SPCR을 사용할 수 없을 때 오탐 오류 메시지 제거.
2.0.1082
- IMDSv2 요청만 하도록 IMDS 대기 로직 업데이트.
- 이미 초기화되었지만 마운트되지 않은 볼륨에 드라이브 문자를 할당하는 로직 추가.
- 키 페어 유형이 지원되지 않을 때 더 구체적인 오류 메시지 출력.
- 3010 재부팅 코드 버그 수정.
- 잘못된 base64 인코딩의 user data 확인 추가.
2.0.1011
- 스크립트 실행 시 로그 출력의 오타 수정.
2.0.1009
- Telemetry가 활성화/비활성화된 프라이버시 제어를 업로드.
- 인덱스 범위 초과 버그 수정.
- sysprep 중 배경화면 바로가기 제거.
2.0.982
- EC2Launch v2 설치 중 레거시 에이전트를 제거하는 로직 추가.
- 루트 볼륨이 볼륨 0으로 나열되지 않을 때 list-volume CLI 문제 수정.
2.0.863
- 스테이지 상태를 올바르게 보고하도록 버그 수정.
- 로그 파일이 닫힐 때 오탐 오류 메시지 제거.
- Telemetry 추가.
2.0.698
- 16진수 IP 호스트 이름에 앞자리 0 추가.
- enableOpenSsh 작업의 파일 권한 수정.
- sysprep 명령 크래시 수정.
2.0.674 / 2.0.651
- DHCP가 인스턴스에 IP를 할당할 때까지 기다리도록 네트워크 스테이지의 버그 수정.
- SearchList 레지스트리 키가 존재하지 않을 때 setDnsSuffix 버그 수정.
- setDnsSuffix의 DNS devolution 로직 버그 수정.
- 중간 재부팅 후 네트워크 라우트 추가.
- initializeVolume이 기존 볼륨의 문자를 다시 지정하도록 허용.
- 버전 하위 명령에서 불필요한 정보 제거.
2.0.592
- 사용자 스크립트를 분리된 프로세스에서 실행하는 옵션 추가.
- 레거시 userdata(XML userdata)가 이제 이전 시작 에이전트와 유사한 동작으로 분리된 프로세스에서 실행.
- 서비스가 중지될 때까지 차단할 수 있는 sysprep 및 reset 명령에 CLI 플래그 추가.
- 구성 폴더 권한 제한.
2.0.548 / 2.0.470
- setHostName 작업에 선택적 hostName 필드 추가.
- 재부팅 버그 수정. executeScript·executeProgram 재부팅 작업이 실행 중으로 표시됩니다.
- status 명령에 더 많은 반환 코드 추가.
- t2.nano 인스턴스 유형에서 실행 시 시작 문제를 수정하는 bootstrap 서비스 추가.
- 설치 프로그램이 추적하지 않는 파일을 제거하도록 깨끗한 설치 모드 수정.
2.0.285
- validate 명령이 잘못된 스테이지 이름을 감지하도록 수정.
- addroutes 작업에 w32tm 다시 동기화 명령 추가.
- DNS 접미사 검색 순서 변경 문제 수정.
- 잘못된 user data를 더 잘 보고하도록 확인 조건 추가.
2.0.207
- 비영어 AMI에서 RootExtend 문제 수정.
- 로그 파일에 사용자 그룹 쓰기 권한 부여.
- GPT 볼륨용 MS Reserved 파티션 생성.
- Amazon EC2Launch 설정에 list-volumes 명령과 볼륨 드롭다운 추가.
- agent-config.yml 파일을 yaml 또는 json 형식으로 출력하는 get-agent-config 명령 추가.
- 공개 키가 감지되지 않으면 정적 암호 지우기.
2.0.160
- 배경화면에 OS 버전 표시 옵션 추가.
- 암호화된 EBS 볼륨 초기화.
- 로컬 DNS 이름이 없는 VPC용 라우트 추가.
2.0.153
- DNS 접미사 검색 목록이 없으면 생성.
- 요청되지 않으면 최대 절전 건너뛰기.