Windows EC2 Fast Launch 문제 해결
Windows EC2 Fast Launch 문제 해결 (Troubleshoot Windows EC2 Fast Launch)
EC2 Fast Launch를 활성화하려고 할 때 겪을 수 있는 일반적인 문제를 진단하고 해결하는 데 도움이 되는 시나리오예요.
출처: 문서
본문
문제 해결 시나리오 (Troubleshooting scenarios)
설명 (Description)
EC2 Fast Launch를 활성화하면 서비스가 사전 프로비저닝된 스냅샷을 만드는 데 사용되는 인스턴스 집합을 시작해요. 각 인스턴스에는 프로세스를 완료하는 데 30분이 주어져요. 인스턴스 중 하나가 성공적으로 완료하면 서비스가 AMI의 Fast Launch 상태를 Enabled로 설정해요. 하지만 인스턴스가 할당된 시간 안에 프로세스를 완료하지 못하고 다른 인스턴스도 프로세스를 완료하지 못했다면, 서비스가 모든 인스턴스를 종료하고 AMI의 Fast Launch 상태를 enabling_failed로, Fast Launch 상태 이유를 다음으로 설정해요.
Unable to stop instance ID=i-1234567890abcdef0 for snapshot creation.
원인 (Cause)
대부분의 경우 실행 중인 인스턴스에서 만들어진 Windows AMI에 대해 EC2 Fast Launch를 활성화하려고 하거나, EC2 Fast Launch 사전 요구 사항을 모두 충족하지 않는 AMI이기 때문에 발생해요.
해결 방법 (Solution)
사용하는 AMI가 모든 EC2 Fast Launch 사전 요구 사항을 충족하는지 확인해요.
AMI에 대해 EC2 Fast Launch를 구성하려면 종료(shutdown) 옵션으로 Sysprep을 사용해 AMI를 만들어야 해요. 자세한 내용은 Windows Sysprep으로 Amazon EC2 AMI 만들기를 참고하세요.
설명 (Description)
시작 템플릿으로 기존 VPC를 지정하지 않고 계정에 기본 VPC가 정의되어 있지 않으면, 서비스가 EC2 Fast Launch 사전 요구 사항에 설명된 대로 VPC와 기타 리소스를 포함하는 CloudFormation 스택을 자동으로 만들어요.
원인 (Cause)
계정이 리전에 대해 허용된 최대 VPC 수에 도달했는데, EC2 Fast Launch가 사용할 기존 VPC를 지정하지 않았어요. 이로 인해 프로세스가 실패해요.
해결 방법 (Solution)
다음 옵션 중 하나로 이 문제를 해결할 수 있어요.
- 쿼터 증가를 요청해요.
- 기존 VPC를 지정하는 시작 템플릿을 제공해요.
계정이 리전당 정의할 수 있는 VPC 수 증가를 요청하려면 다음 단계를 따라요.
- Service Quotas 콘솔(https://console.aws.amazon.com/servicequotas/)을 엽니다.
- Service Console Dashboard에서 **Amazon Virtual Private Cloud (Amazon VPC)**를 선택해요. VPC 서비스 쿼터가 열려요.
- VPCs per Region으로 필터링해 쿼터로 바로 이동해요.
- VPCs per Region을 선택하고 Request increase at account level을 선택해요.
긴급한 쿼터 요청이 있거나 쿼터 증가 요청이 거부되면 Support에 도움을 요청하세요. 자세한 내용은 Service Quotas User Guide의 쿼터 증가 요청을 참고하세요.
설명 (Description)
Launch Template을 지정하지 않고 EC2 Fast Launch를 처음 활성화하면, EC2 Fast Launch가 서비스 소유 CloudFormation 스택을 서비스 기본 리소스로 만들어요. 하지만 IAM 주체(역할 또는 사용자)에 필요한 권한이 없으면 CloudFormation 템플릿 배포가 실패해요.
로그 메시지는 다음과 비슷할 수 있어요.
Can't enable EC2 Fast Launch. The IAM credentials that you are using do not have sufficient permissions. Attach EC2FastLaunchFullAccess in the IAM console.
원인 (Cause)
IAM 사용자나 역할에 EC2 Fast Launch를 활성화하는 데 필요한 권한이 없어요.
해결 방법 (Solution)
EC2 Fast Launch를 활성화하는 IAM 주체(사용자 또는 역할)에 EC2FastLaunchFullAccess 정책이 연결되어 있는지 확인해요. 이 AWS 관리형 정책은 모든 EC2 Fast Launch 리소스에 대한 전체 접근 권한을 부여해요. 이 정책의 권한을 보려면 AWS Managed Policy Reference의 EC2FastLaunchFullAccess 정책을 참고하세요.