Multi-Region Access Point 옵트인 리전 구성
Multi-Region Access Point 옵트인 리전 구성
AWS 옵트인 리전은 AWS 계정에서 기본적으로 활성화되지 않은 리전이에요. 반대로 기본적으로 활성화된 리전은 AWS 리전 또는 상용 리전이라고 불러요.
AWS 옵트인 리전에서 Multi-Region Access Points를 사용하려면 Multi-Region Access Point를 만들기 전에 계정에 대해 옵트인 리전을 수동으로 활성화해야 해요. 옵트인 리전을 활성화한 뒤에는 선택한 옵트인 리전의 버킷으로 Multi-Region Access Points를 만들 수 있어요. AWS 계정 또는 AWS Organization에 대해 옵트인 리전을 활성화하거나 비활성화하는 방법에 대한 지침은 독립 실행형 계정에 대한 리전 활성화 또는 비활성화 또는 조직에서 리전 활성화 또는 비활성화 문서를 참고하세요.
참고: Multi-Region Access Point 옵트인 리전은 현재 AWS SDK와 AWS CLI로만 지원돼요.
S3 Multi-Region Access Points는 다음 AWS 옵트인 리전을 지원합니다.
- 아프리카(케이프타운)
- 아시아 태평양(홍콩)
- 아시아 태평양(자카르타)
- 아시아 태평양(멜버른)
- 아시아 태평양(하이데라바드)
- 캐나다 서부(캘거리)
- 유럽(취리히)
- 유럽(밀라노)
- 유럽(스페인)
- 이스라엘(텔아비브)
- 중동(바레인)
- 중동(UAE)
참고: 옵트인 리전을 활성화하는 데 추가 비용은 없어요. 다만 Multi-Region Access Point에서 리소스를 만들거나 사용하면 청구 요금이 발생합니다.
출처: 문서
AWS 옵트인 리전에서 Multi-Region Access Point 사용
Multi-Region Access Point에 대해 데이터 플레인 작업을 수행하려면 연결된 모든 AWS 계정이 Multi-Region Access Point의 일부인 옵트인 리전을 활성화해야 해요. 이 요구 사항은 요청자 계정, Multi-Region Access Point 소유자, S3 버킷 소유자, VPC 엔드포인트 소유자 모두에 적용됩니다. 이 계정 중 하나라도 AWS 옵트인 리전을 활성화하지 않으면 Multi-Region Access Point 요청이 실패해요. InvalidToken 또는 AllAccessDisabled 오류에 대한 자세한 내용은 오류 코드 목록 문서를 참고하세요.
참고: Multi-Region Access Point 정책을 갱신하거나 페일오버 구성을 갱신하는 것 같은 제어 플레인 작업은 Multi-Region Access Point의 일부인 어떤 리전의 옵트인 상태에도 영향을 받지 않아요. Multi-Region Access Point를 삭제하기 전에 활성 옵트인 리전을 비활성화할 필요도 없습니다.
활성 AWS 옵트인 리전 비활성화
Multi-Region Access Point의 일부인 옵트인 리전을 비활성화하면 이 리전으로 라우팅되는 요청에서 403 AllAccessDisabled 오류가 발생해요. 옵트인 리전을 안전하게 비활성화하려면 먼저 Multi-Region Access Point 구성에서 트래픽을 라우팅할 대체 리전을 식별하는 걸 권장해요. 그런 다음 Multi-Region Access Point 페일오버 컨트롤을 사용해 대체 리전을 활성으로 표시하고, 비활성화할 리전을 패시브로 표시해요. 페일오버 컨트롤을 변경한 뒤에는 옵트아웃하려는 리전을 비활성화할 수 있어요.
이전에 비활성화한 AWS 옵트인 리전 활성화
Multi-Region Access Point에 대해 이전에 비활성화했던 AWS 옵트인 리전을 활성화하려면 AWS 계정 설정을 갱신했는지 확인하세요. 옵트인 리전을 다시 활성화한 뒤에는 PutMultiRegionAccessPointPolicy API 작업을 실행해 Multi-Region Access Points 정책을 옵트인 리전에 적용해요.
VPC 엔드포인트를 통해 Multi-Region Access Point에 액세스한다면 VPCE 정책을 갱신하고 ModifyVpcEndpoint API 작업을 사용해 갱신된 VPC 엔드포인트 정책을 다시 활성화된 옵트인 리전에 적용하는 걸 권장해요.
Multi-Region Access Points 정책과 여러 AWS 계정
Multi-Region Access Points 정책이 여러 AWS 계정에 액세스를 부여한다면 모든 요청자 계정도 계정 설정에서 같은 옵트인 리전을 활성화해야 해요. 요청자 계정이 Multi-Region Access Point의 일부인 옵트인 리전을 활성화하지 않은 채 Multi-Region Access Point 요청을 제출하면 400 InvalidToken 오류가 발생합니다.
AWS 옵트인 리전 고려 사항
옵트인 리전에서 Multi-Region Access Point에 액세스할 때 다음 사항에 유의하세요.
- 옵트인 리전을 활성화하면 그 옵트인 리전의 버킷을 사용해 Multi-Region Access Point를 만들 수 있어요. 옵트인 리전을 비활성화하면 Multi-Region Access Point가 그 옵트인 리전에서 더 이상 지원되지 않습니다. Multi-Region Access Point에 대해 옵트인 리전을 더 이상 활성화해 두고 싶지 않다면 먼저 계정에 대한 리전을 비활성화한 뒤, 원하는 옵트인 리전 목록으로 새 Multi-Region Access Point를 만들어야 해요.
- 비활성화된 옵트인 리전으로 Multi-Region Access Point를 만들려 하면
403 InvalidRegion오류를 받게 됩니다. 옵트인 리전을 활성화한 뒤 다시 Multi-Region Access Point 만들기를 시도하세요. - Multi-Region Access Point가 지원하는 최대 리전 수는 17개예요. 여기에는 옵트인 리전과 상용 리전이 모두 포함됩니다. 자세한 내용은 Multi-Region Access Points 제한 사항 및 한계 문서를 참고하세요.
- 어떤 리전에도 옵트인하지 않았더라도 Multi-Region Access Points에 대한 제어 플레인 요청은 작동해요.
- 처음으로 Multi-Region Access Point를 만들려 할 때는 Multi-Region Access Point의 일부인 모든 리전에 옵트인해야 합니다.
- Multi-Region Access Point 정책을 통해 S3 Multi-Region Access Point에 액세스 권한이 부여된 모든 AWS 계정도 Multi-Region Access Point의 일부인 같은 옵트인 리전을 활성화해야 해요.