Amazon S3 Multi-Region Access Point 페일오버 컨트롤 오류

Amazon S3 Multi-Region Access Point 페일오버 컨트롤 오류

Multi-Region Access Point의 페일오버 구성을 갱신할 때 다음 오류 중 하나를 만날 수 있어요.

  • HTTP 400 Bad Request – 페일오버 구성을 갱신할 때 유효하지 않은 Multi-Region Access Point ARN을 입력하면 이 오류가 발생할 수 있어요. Multi-Region Access Point 정책을 검토해서 Multi-Region Access Point ARN을 확인할 수 있어요. Multi-Region Access Point 정책을 검토하거나 갱신하려면 Multi-Region Access Point 정책 편집 문서를 참고하세요. 이 오류는 Amazon S3 Multi-Region Access Point 페일오버 컨트롤을 갱신할 때 빈 문자열이나 임의의 문자열을 사용해도 발생할 수 있어요. Multi-Region Access Point ARN 형식을 사용해야 합니다: arn:aws:s3::account-id:accesspoint/MultiRegionAccessPoint_alias
  • HTTP 503 Slow Down – 짧은 시간 안에 너무 많은 요청을 보내면 이 오류가 발생해요. 거부된 요청은 오류를 초래합니다.
  • HTTP 409 Conflict – 둘 이상의 동시 라우트 구성 갱신 요청이 단일 Multi-Region Access Point를 대상으로 할 때 이 오류가 발생해요. 첫 번째 요청은 성공하고 다른 요청은 오류로 실패합니다.
  • HTTP 405 Method Not Allowed – 페일오버를 시작할 때 AWS 리전이 하나만 있는 Multi-Region Access Point를 선택하면 이 오류가 발생해요. 페일오버를 시작하려면 먼저 두 리전을 선택해야 해요. 그렇지 않으면 오류가 반환됩니다.

출처: 문서

관련 주제