트랜잭션 로그 백업 액세스 문제 해결하기
트랜잭션 로그 백업 액세스 문제 해결하기
트랜잭션 로그 백업 액세스용 저장 프로시저를 사용할 때 흔히 마주칠 수 있는 오류들을 정리했어요. 오류 메시지를 확인하고 원인과 해결 방법을 함께 살펴보면서 문제를 해결해 볼게요.
출처: 문서
본문
다음은 트랜잭션 로그 백업 액세스를 위한 저장 프로시저를 사용할 때 발생할 수 있는 문제들이에요.
rds_tlog_copy_setup
오류 메시지: Backups are disabled on this DB instance. Enable DB instance backups with a retention of at least "1" and try again.
- 문제: DB 인스턴스에 자동 백업이 활성화되어 있지 않아요.
- 해결: DB 인스턴스 백업 보존을 최소 하루 이상으로 활성화해야 해요. 자동 백업 활성화 및 백업 보존 구성에 대한 자세한 내용은 백업 보존 기간을 참조하세요.
오류 메시지: Error running the rds_tlog_copy_setup stored procedure. Reconnect to the RDS endpoint and try again.
- 문제: 내부 오류가 발생했어요.
- 해결: RDS 엔드포인트에 다시 연결하고
rds_tlog_copy_setup저장 프로시저를 다시 실행하세요.
오류 메시지: Running the rds_tlog_backup_copy_setup stored procedure inside a transaction is not supported. Verify that the session has no open transactions and try again.
- 문제:
BEGIN과END를 사용하는 트랜잭션 내에서 프로시저를 실행하려 했어요. - 해결:
rds_tlog_copy_setup저장 프로시저를 실행할 때는BEGIN과END를 사용하지 마세요.
오류 메시지: The S3 bucket name for the input parameter @target_s3_arn should contain at least one character other than a space.
- 문제: 입력 매개변수
@target_s3_arn에 잘못된 값이 제공됐어요. - 해결: 입력 매개변수
@target_s3_arn에 전체 Amazon S3 버킷 ARN이 지정되어 있는지 확인하세요.
오류 메시지: The SQLSERVER_BACKUP_RESTORE option isn't enabled or is in the process of being enabled. Enable the option or try again later.
- 문제: DB 인스턴스에서
SQLSERVER_BACKUP_RESTORE옵션이 활성화되어 있지 않거나 방금 활성화되어 내부 활성화가 대기 중이에요. - 해결: 요구 사항 섹션에 지정된 대로
SQLSERVER_BACKUP_RESTORE옵션을 활성화하세요. 몇 분 기다린 후rds_tlog_copy_setup저장 프로시저를 다시 실행하세요.
오류 메시지: The target S3 arn for the input parameter @target_s3_arn can't be empty or null.
- 문제: 입력 매개변수
@target_s3_arn에NULL값이 제공되었거나 값이 제공되지 않았어요. - 해결: 입력 매개변수
@target_s3_arn에 전체 Amazon S3 버킷 ARN이 지정되어 있는지 확인하세요.
오류 메시지: The target S3 arn for the input parameter @target_s3_arn must begin with arn:aws.
- 문제: 입력 매개변수
@target_s3_arn이 앞에arn:aws없이 제공됐어요. - 해결: 입력 매개변수
@target_s3_arn에 전체 Amazon S3 버킷 ARN이 지정되어 있는지 확인하세요.
오류 메시지: The target S3 ARN is already set to the provided value.
- 문제:
rds_tlog_copy_setup저장 프로시저가 이전에 실행되어 Amazon S3 버킷 ARN이 이미 구성되어 있어요. - 해결: 트랜잭션 로그 백업 액세스를 위한 Amazon S3 버킷 값을 수정하려면 다른
target S3 ARN을 제공하세요.
오류 메시지: Unable to generate credentials for enabling Access to Transaction Log Backups. Confirm the S3 path ARN provided with rds_tlog_copy_setup and try again later.
- 문제: 트랜잭션 로그 백업 액세스를 활성화하기 위한 자격 증명을 생성하는 동안 지정되지 않은 오류가 발생했어요.
- 해결: 설정 구성을 검토하고 다시 시도하세요.
오류 메시지: You cannot run the rds_tlog_copy_setup stored procedure while there are pending tasks. Wait for the pending tasks to complete and try again.
- 문제: 한 번에 두 개의 작업만 실행할 수 있는데 완료 대기 중인 작업이 있어요.
- 해결: 대기 중인 작업을 확인하고 완료될 때까지 기다리세요. 작업 상태 모니터링에 대한 자세한 내용은 작업 상태 추적하기를 참조하세요.
rds_tlog_backup_copy_to_S3
오류 메시지: A T-log backup file copy task has already been issued for database: %s with task Id: %d, please try again later.
- 문제: 주어진 데이터베이스에 대해 한 번에 하나의 복사 작업만 실행할 수 있는데 완료 대기 중인 복사 작업이 있어요.
- 해결: 대기 중인 작업을 확인하고 완료될 때까지 기다리세요. 작업 상태 모니터링에 대한 자세한 내용은 작업 상태 추적하기를 참조하세요.
오류 메시지: At least one of these three parameter sets must be provided. SET-1:(@backup_file_start_time, @backup_file_end_time) | SET-2:(@starting_lsn, @ending_lsn) | SET-3:(@rds_backup_starting_seq_id, @rds_backup_ending_seq_id)
- 문제: 세 매개변수 세트 중 어느 것도 제공되지 않았거나, 제공된 세트에 필수 매개변수가 누락됐어요.
- 해결: 시간, LSN 또는 시퀀스 ID 매개변수 중 하나를 지정할 수 있어요. 이 세 세트 중 하나가 필요해요. 필수 매개변수에 대한 자세한 내용은 트랜잭션 로그 백업 복사하기를 참조하세요.
오류 메시지: Backups are disabled on your instance. Please enable backups and try again in some time.
- 문제: DB 인스턴스에 자동 백업이 활성화되어 있지 않아요.
- 해결: 자동 백업 활성화 및 백업 보존 구성에 대한 자세한 내용은 백업 보존 기간을 참조하세요.
오류 메시지: Cannot find the given database %s.
- 문제: 입력 매개변수
@db_name에 제공된 값이 DB 인스턴스의 데이터베이스 이름과 일치하지 않아요. - 해결: 올바른 데이터베이스 이름을 사용하세요. 모든 데이터베이스를 이름별로 나열하려면
SELECT * from sys.databases를 실행하세요.
오류 메시지: Cannot run the rds_tlog_backup_copy_to_S3 stored procedure for SQL Server system databases or the rdsadmin database.
- 문제: 입력 매개변수
@db_name에 제공된 값이 SQL Server 시스템 데이터베이스 이름 또는 RDSAdmin 데이터베이스와 일치해요. - 해결: 트랜잭션 로그 백업 액세스에는 다음 데이터베이스를 사용할 수 없어요:
master, model, msdb, tempdb, RDSAdmin.
오류 메시지: Database name for the input parameter @db_name can't be empty or null.
- 문제: 입력 매개변수
@db_name에 제공된 값이 비어 있거나NULL이에요. - 해결: 올바른 데이터베이스 이름을 사용하세요. 모든 데이터베이스를 이름별로 나열하려면
SELECT * from sys.databases를 실행하세요.
오류 메시지: DB instance backup retention period must be set to at least 1 to run the rds_tlog_backup_copy_setup stored procedure.
- 문제: DB 인스턴스에 자동 백업이 활성화되어 있지 않아요.
- 해결: 자동 백업 활성화 및 백업 보존 구성에 대한 자세한 내용은 백업 보존 기간을 참조하세요.
오류 메시지: Error running the stored procedure rds_tlog_backup_copy_to_S3. Reconnect to the RDS endpoint and try again.
- 문제: 내부 오류가 발생했어요.
- 해결: RDS 엔드포인트에 다시 연결하고
rds_tlog_backup_copy_to_S3저장 프로시저를 다시 실행하세요.
오류 메시지: Only one of these three parameter sets can be provided. SET-1:(@backup_file_start_time, @backup_file_end_time) | SET-2:(@starting_lsn, @ending_lsn) | SET-3:(@rds_backup_starting_seq_id, @rds_backup_ending_seq_id)
- 문제: 여러 매개변수 세트가 제공됐어요.
- 해결: 시간, LSN 또는 시퀀스 ID 매개변수 중 하나를 지정할 수 있어요. 이 세 세트 중 하나가 필요해요. 필수 매개변수에 대한 자세한 내용은 트랜잭션 로그 백업 복사하기를 참조하세요.
오류 메시지: Running the rds_tlog_backup_copy_to_S3 stored procedure inside a transaction is not supported. Verify that the session has no open transactions and try again.
- 문제:
BEGIN과END를 사용하는 트랜잭션 내에서 프로시저를 실행하려 했어요. - 해결:
rds_tlog_backup_copy_to_S3저장 프로시저를 실행할 때는BEGIN과END를 사용하지 마세요.
오류 메시지: The provided parameters fall outside of the transaction backup log retention period. To list of available transaction log backup files, run the rds_fn_list_tlog_backup_metadata function.
- 문제: 제공된 입력 매개변수에 대해 복사 보존 기간 안에 맞는 사용 가능한 트랜잭션 로그 백업이 없어요.
- 해결: 유효한 매개변수 세트로 다시 시도하세요. 필수 매개변수에 대한 자세한 내용은 트랜잭션 로그 백업 복사하기를 참조하세요.
오류 메시지: There was a permissions error in processing the request. Ensure the bucket is in the same Account and Region as the DB Instance, and confirm the S3 bucket policy permissions against the template in the public documentation.
- 문제: 제공된 S3 버킷 또는 그 정책 권한에서 문제가 감지됐어요.
- 해결: 트랜잭션 로그 백업 액세스 설정이 올바른지 확인하세요. S3 버킷 설정 요구 사항에 대한 자세한 내용은 요구 사항을 참조하세요.
오류 메시지: Running the rds_tlog_backup_copy_to_S3 stored procedure on an RDS read replica instance isn't permitted.
- 문제: RDS 읽기 전용 복제본 인스턴스에서 프로시저를 실행하려 했어요.
- 해결: RDS 프라이머리 DB 인스턴스에 연결하여
rds_tlog_backup_copy_to_S3저장 프로시저를 실행하세요.
오류 메시지: The LSN for the input parameter @starting_lsn must be less than @ending_lsn.
- 문제: 입력 매개변수
@starting_lsn에 제공된 값이 입력 매개변수@ending_lsn의 값보다 컸어요. - 해결: 입력 매개변수
@starting_lsn에 제공된 값이@ending_lsn값보다 작은지 확인하세요.
오류 메시지: The rds_tlog_backup_copy_to_S3 stored procedure can only be performed by the members of db_owner role in the source database.
- 문제: 제공된
db_name에서rds_tlog_backup_copy_to_S3저장 프로시저를 실행하려는 계정에db_owner역할이 부여되지 않았어요. - 해결: 프로시저를 실행하는 계정에 제공된
db_name에 대한db_owner역할 권한이 있는지 확인하세요.
오류 메시지: The sequence ID for the input parameter @rds_backup_starting_seq_id must be less than or equal to @rds_backup_ending_seq_id.
- 문제: 입력 매개변수
@rds_backup_starting_seq_id에 제공된 값이 입력 매개변수@rds_backup_ending_seq_id의 값보다 컸어요. - 해결: 입력 매개변수
@rds_backup_starting_seq_id에 제공된 값이@rds_backup_ending_seq_id값보다 작은지 확인하세요.
오류 메시지: The SQLSERVER_BACKUP_RESTORE option isn't enabled or is in the process of being enabled. Enable the option or try again later.
- 문제: DB 인스턴스에서
SQLSERVER_BACKUP_RESTORE옵션이 활성화되어 있지 않거나 방금 활성화되어 내부 활성화가 대기 중이에요. - 해결: 요구 사항 섹션에 지정된 대로
SQLSERVER_BACKUP_RESTORE옵션을 활성화하세요. 몇 분 기다린 후rds_tlog_backup_copy_to_S3저장 프로시저를 다시 실행하세요.
오류 메시지: The start time for the input parameter @backup_file_start_time must be less than @backup_file_end_time.
- 문제: 입력 매개변수
@backup_file_start_time에 제공된 값이 입력 매개변수@backup_file_end_time의 값보다 컸어요. - 해결: 입력 매개변수
@backup_file_start_time에 제공된 값이@backup_file_end_time값보다 작은지 확인하세요.
오류 메시지: We were unable to process the request due to a lack of access. Please check your setup and permissions for the feature.
- 문제: Amazon S3 버킷 권한에 문제가 있거나, 제공된 Amazon S3 버킷이 다른 계정이나 리전에 있을 수 있어요.
- 해결: Amazon S3 버킷 정책 권한이 RDS 액세스를 허용하도록 권한이 부여되었는지 확인하세요. Amazon S3 버킷이 DB 인스턴스와 동일한 계정 및 리전에 있는지 확인하세요.
오류 메시지: You cannot provide a KMS Key ARN as input parameter to the stored procedure for instances that are not storage-encrypted.
- 문제: DB 인스턴스에 스토리지 암호화가 활성화되지 않은 경우 입력 매개변수
@kms_key_arn을 제공하면 안 돼요. - 해결:
@kms_key_arn에 입력 매개변수를 제공하지 마세요.
오류 메시지: You must provide a KMS Key ARN as input parameter to the stored procedure for storage encrypted instances.
- 문제: DB 인스턴스에 스토리지 암호화가 활성화된 경우 입력 매개변수
@kms_key_arn을 제공해야 해요. - 해결: 트랜잭션 로그 백업에 사용할 Amazon S3 버킷의 ARN과 일치하는 값으로
@kms_key_arn입력 매개변수를 제공하세요.
오류 메시지: You must run the rds_tlog_copy_setup stored procedure and set the @target_s3_arn, before running the rds_tlog_backup_copy_to_S3 stored procedure.
- 문제:
rds_tlog_backup_copy_to_S3저장 프로시저를 실행하기 전에 트랜잭션 로그 백업 액세스 설정 프로시저를 완료하지 않았어요. - 해결:
rds_tlog_backup_copy_to_S3저장 프로시저를 실행하기 전에rds_tlog_copy_setup저장 프로시저를 실행하세요. 트랜잭션 로그 백업 액세스 설정 프로시저 실행에 대한 자세한 내용은 트랜잭션 로그 백업 액세스 설정하기를 참조하세요.