RDS for MySQL 데이터베이스 로그 개요
RDS for MySQL 데이터베이스 로그 개요
다음 유형의 RDS for MySQL 로그 파일을 모니터링할 수 있어요:
- 오류 로그(error log)
- 느린 쿼리 로그(slow query log)
- 일반 로그(general log)
- 감사 로그(audit log)
- 인스턴스 로그(instance log)
- IAM 데이터베이스 인증 오류 로그(IAM database authentication error log)
RDS for MySQL 오류 로그는 기본적으로 생성돼요. DB 파라미터 그룹에서 파라미터를 설정해 느린 쿼리 로그와 일반 로그를 생성할 수 있어요.
출처: 문서
본문
RDS for MySQL 데이터베이스 로그 개요
다음 유형의 RDS for MySQL 로그 파일을 모니터링할 수 있어요:
- 오류 로그
- 느린 쿼리 로그
- 일반 로그
- 감사 로그
- 인스턴스 로그
- IAM 데이터베이스 인증 오류 로그
RDS for MySQL 오류 로그는 기본적으로 생성돼요. DB 파라미터 그룹에서 파라미터를 설정해 느린 쿼리 로그와 일반 로그를 생성할 수 있어요.
관련 주제
- RDS for MySQL 오류 로그
- RDS for MySQL 느린 쿼리 로그 및 일반 로그
- MySQL 감사 로그
- RDS for MySQL 로그 순환 및 보존
- redo 로그 크기 제한
RDS for MySQL 오류 로그
RDS for MySQL은 mysql-error.log 파일에 오류를 기록해요. 각 로그 파일 이름에는 생성된 시간(UTC)이 추가돼요. 로그 파일에는 로그 항목이 기록된 시점을 파악하는 데 도움이 되는 타임스탬프도 있어요.
RDS for MySQL은 시작, 종료, 오류가 발생했을 때만 오류 로그에 기록해요. DB 인스턴스는 오류 로그에 새 항목이 기록되지 않고 몇 시간 또는 며칠이 지날 수 있어요. 최근 항목이 보이지 않는다면 서버가 로그 항목을 생성할 오류를 만나지 않았기 때문이에요.
설계상 오류 로그는 오류 같은 예기치 않은 이벤트만 표시되도록 필터링돼요. 그러나 오류 로그에는 쿼리 진행 상황처럼 표시되지 않는 추가 데이터베이스 정보도 포함돼요. 따라서 실제 오류가 없더라도 지속적인 데이터베이스 활동 때문에 오류 로그 크기가 커질 수 있어요. AWS Management Console에서 오류 로그에 특정 바이트 또는 킬로바이트 크기가 표시되더라도 실제 다운로드하면 0바이트일 수 있어요.
RDS for MySQL은 5분마다 mysql-error.log를 디스크에 기록하고, 로그 내용을 mysql-error-running.log에 추가해요.
RDS for MySQL은 매시간 mysql-error-running.log 파일을 순환(rotate)해요. 지난 2주 동안 생성된 로그를 보존해요.
참고
로그 보존 기간은 Amazon RDS와 Aurora 간에 다릅니다.