RDS for Db2 복제본 생성을 위한 준비

RDS for Db2 복제본 생성을 위한 준비

이 문서는 Amazon RDS 사용자 가이드의 Db2 관련 페이지를 한국어로 설명합니다.

출처: 문서

본문

RDS for Db2 복제본을 생성하기 전에 복제가 성공적으로 이루어지도록 다음 작업을 완료해야 합니다. 이러한 작업은 일반적인 문제를 방지하고 최적의 성능을 보장하는 데 도움이 됩니다.

작업 1: 자동 백업 활성화

DB 인스턴스가 소스 DB 인스턴스로 사용되려면 먼저 소스 DB 인스턴스에서 자동 백업을 활성화해야 합니다. 이는 모든 복제본 생성 작업의 전제 조건입니다. 이 절차를 수행하는 방법은 자동 백업 활성화하기를 참조하세요.

Db2 복제본에 특화된 백업에 대한 정보는 RDS for Db2 복제본 백업 작업을 참조하세요.

작업 2: 컴퓨팅 및 스토리지 리소스 계획

소스 DB 인스턴스와 그 복제본이 운영 부하에 맞게 컴퓨팅과 스토리지 측면에서 적절히 크기가 조정되었는지 확인하세요. 복제본이 컴퓨팅, 네트워크 또는 스토리지 리소스 용량에 도달하면 복제본은 소스에서 변경 사항을 받거나 적용하는 것을 중단합니다. 복제본 성능과 리소스 사용률 모니터링에 대한 정보는 읽기 복제 모니터링하기를 참조하세요.

RDS for Db2는 소스 DB 인스턴스와 그 복제본 사이의 높은 복제 지연(replica lag)을 완화하기 위해 개입하지 않습니다. 높은 복제 지연이 발생하는 경우 문제 해결 지침은 Db2 복제 지연 모니터링하기를 참조하세요.

복제본의 스토리지와 CPU 리소스는 소스 및 다른 복제본과 독립적으로 수정할 수 있습니다. 자세한 내용은 Amazon RDS DB 인스턴스 수정하기를 참조하세요.

작업 3: 데이터베이스 준비

복제본을 생성하기 전에 다음 사항을 기준으로 데이터베이스가 준비되었는지 확인하세요.

  • DB 인스턴스에 DB 인스턴스에 존재시키려는 모든 데이터베이스가 포함되어 있는지 확인합니다. 복제본 생성 후에는 DB 인스턴스에서 데이터베이스를 생성, 삭제 또는 네이티브 복원할 수 없습니다. rdsadmin.create_database, rdsadmin.drop_database 또는 rdsadmin.restore_database 저장 프로시저에 대한 모든 호출이 실패합니다.
  • DB 인스턴스의 모든 데이터베이스가 활성 상태인지 확인합니다. 어떤 데이터베이스라도 비활성 상태이면 복제본 생성이 실패합니다. 데이터베이스 활성화에 대한 정보는 RDS for Db2용 데이터베이스 저장 프로시저를 참조하세요.

다음 단계

모든 준비 작업을 완료한 후 Db2 복제본을 생성할 준비가 되었습니다.

  • 읽기 전용 복제본을 생성하려면 읽기 복제본 생성하기를 참조하세요.
  • 대기 복제본을 생성하려면 대기 Db2 복제본 생성하기를 참조하세요.

더 알아보기 (Learn more)