Amazon RDS for SQL Server에서 로그 시퀀스 번호 차이로 인한 특정 시점 복구 실패 문제 해결

Amazon RDS for SQL Server에서 로그 시퀀스 번호 차이로 인한 특정 시점 복구 실패 문제 해결

RDS for SQL Server에서 특정 시점 복구(PITR)를 시도할 때 로그 시퀀스 번호(LSN) 차이 때문에 실패가 발생할 수 있어요. 이러한 차이로 인해 RDS가 요청된 시점으로 데이터베이스를 복원하지 못하며, RDS는 복원 인스턴스를 incompatible-restore 상태로 둡니다.

출처: 문서

본문

이 문제의 일반적인 원인은 다음과 같습니다.

  • 데이터베이스 복구 모델을 수동으로 변경한 경우.
  • 트랜잭션 로그 백업을 완료하기 위한 리소스가 부족하여 RDS가 복구 모델을 자동으로 변경한 경우.

데이터베이스의 LSN 차이를 식별하려면 이 쿼리를 실행하세요.

더 알아보기 (Learn more)