자체 관리형 Active Directory 문제 해결
자체 관리형 Active Directory 문제 해결
Amazon RDS 사용자 가이드의 이 페이지를 한국어로 설명합니다.
출처: 문서
본문
자체 관리형 Active Directory 문제 해결
다음은 자체 관리형 AD를 설정하거나 수정할 때 발생할 수 있는 문제입니다.
| 오류 코드 | 설명 | 일반적인 원인 | 문제 해결 제안 |
|---|---|---|---|
| 오류 2 / 0x2 | 시스템이 지정된 파일을 찾을 수 없습니다. | --domain-ou 파라미터로 지정된 OU(조직 구성 단위)의 형식 또는 위치가 잘못되었습니다. AWS Secrets Manager를 통해 지정된 도메인 서비스 계정에 OU에 가입하는 데 필요한 권한이 없습니다. |
--domain-ou 파라미터를 검토하세요. 도메인 서비스 계정에 OU에 대한 올바른 권한이 있는지 확인합니다. 자세한 내용은 AD 도메인 서비스 계정 구성을 참조하세요. |
| 오류 5 / 0x5 | 액세스가 거부되었습니다. | 도메인 서비스 계정의 권한이 잘못 구성되었거나 컴퓨터 계정이 도메인에 이미 존재합니다. | 도메인의 도메인 서비스 계정 권한을 검토하고 RDS 컴퓨터 계정이 도메인에서 중복되지 않는지 확인합니다. RDS for SQL Server DB 인스턴스에서 SELECT @@SERVERNAME을 실행하여 RDS 컴퓨터 계정 이름을 확인할 수 있습니다. Multi-AZ를 사용하는 경우 장애 조치로 재부팅한 후 RDS 컴퓨터 계정을 다시 확인합니다. 자세한 내용은 DB 인스턴스 재부팅을 참조하세요. |
| 오류 87 / 0x57 | 파라미터가 올바르지 않습니다. | AWS Secrets Manager를 통해 지정된 도메인 서비스 계정에 올바른 권한이 없습니다. 사용자 프로필이 손상되었을 수도 있습니다. | 도메인 서비스 계정의 요구 사항을 검토합니다. 자세한 내용은 AD 도메인 서비스 계정 구성을 참조하세요. |
| 오류 234 / 0xEA | 지정된 OU(조직 구성 단위)가 존재하지 않습니다. | --domain-ou 파라미터로 지정된 OU가 자체 관리형 AD에 존재하지 않습니다. |
--domain-ou 파라미터를 검토하고 지정된 OU가 자체 관리형 AD에 존재하는지 확인합니다. |
| 오류 1326 / 0x52E | 사용자 이름 또는 비밀번호가 올바르지 않습니다. | AWS Secrets Manager에 제공된 도메인 서비스 계정 자격 증명에 알 수 없는 사용자 이름 또는 잘못된 비밀번호가 포함되어 있습니다. 도메인 계정이 자체 관리형 AD에서 비활성화되었을 수도 있습니다. | AWS Secrets Manager에 제공된 자격 증명이 올바른지, 도메인 계정이 자체 관리형 AD에서 활성화되어 있는지 확인합니다. |
| 오류 1355 / 0x54B | 지정된 도메인이 존재하지 않거나 연결할 수 없습니다. | 도메인이 다운되었거나, 지정된 DNS IP 세트에 연결할 수 없거나, 지정된 FQDN에 연결할 수 없습니다. | --domain-dns-ips 및 --domain-fqdn 파라미터를 검토하여 올바른지 확인합니다. RDS for SQL Server DB 인스턴스의 네트워킹 구성을 검토하고 자체 관리형 AD에 연결할 수 있는지 확인합니다. 자세한 내용은 네트워크 연결 구성을 참조하세요. |
| 오류 1722 / 0x6BA | RPC 서버를 사용할 수 없습니다. | AD 도메인의 RPC 서비스에 연결하는 데 문제가 있었습니다. 서비스 또는 네트워크 문제일 수 있습니다. | 도메인 컨트롤러에서 RPC 서비스가 실행 중인지, RDS for SQL Server DB 인스턴스에서 도메인의 TCP 포트 135 및 49152-65535에 연결할 수 있는지 확인합니다. |
| 오류 1727 / 0x6BF | 원격 프로시저 호출이 실패하여 실행되지 않았습니다. | 도메인 컨트롤러에 대한 RPC 통신을 차단하는 네트워크 연결 문제 또는 방화벽 제한. | 크로스 VPC 도메인 가입을 사용하는 경우 VPC 피어링 또는 Transit Gateway로 크로스 VPC 통신이 올바르게 설정되었는지 확인합니다. 가능한 방화벽 제한을 포함하여 RDS for SQL Server DB 인스턴스에서 도메인의 TCP 상위 포트 49152-65535에 연결할 수 있는지 확인합니다. |
| 오류 2224 / 0x8B0 | 사용자 계정이 이미 존재합니다. | 자체 관리형 AD에 추가하려고 하는 컴퓨터 계정이 이미 존재합니다. | RDS for SQL Server DB 인스턴스에서 SELECT @@SERVERNAME을 실행하여 컴퓨터 계정을 식별한 다음 자체 관리형 AD에서 신중하게 제거합니다. |
| 오류 2242 / 0x8c2 | 이 사용자의 비밀번호가 만료되었습니다. | AWS Secrets Manager를 통해 지정된 도메인 서비스 계정의 비밀번호가 만료되었습니다. | RDS for SQL Server DB 인스턴스를 자체 관리형 AD에 가입시키는 데 사용되는 도메인 서비스 계정의 비밀번호를 업데이트합니다. |