문제 해결

문제 해결

Amazon RDS 사용자 가이드의 이 페이지를 한국어로 설명합니다.

출처: 문서

본문

문제 해결

다음은 네이티브 백업 및 복원을 사용할 때 발생할 수 있는 문제입니다.

문제 문제 해결 제안
데이터베이스 백업/복원 옵션이 아직 활성화되지 않았거나 활성화하는 중입니다. 나중에 다시 시도하세요. DB 인스턴스와 연결된 DB 옵션 그룹에 SQLSERVER_BACKUP_RESTORE 옵션을 추가했는지 확인합니다. 자세한 내용은 네이티브 백업 및 복원 옵션 추가를 참조하세요.
'rds_backup_database' 개체, 'msdb' 데이터베이스, 'dbo' 스키마에 대한 EXECUTE 권한이 거부되었습니다. 저장 프로시저를 실행할 때 마스터 사용자를 사용하고 있는지 확인합니다. 마스터 사용자로 로그인한 후에도 이 오류가 발생하면 관리자 사용자 권한이 정렬되지 않았기 때문일 수 있습니다. 마스터 사용자를 재설정하려면 AWS Management Console을 사용하세요. Amazon RDS for SQL Server의 마스터 사용자에 대한 db_owner 역할 멤버십 재설정을 참조하세요.
'rds_restore_database' 개체, 'msdb' 데이터베이스, 'dbo' 스키마에 대한 EXECUTE 권한이 거부되었습니다. 저장 프로시저를 실행할 때 마스터 사용자를 사용하고 있는지 확인합니다. 마스터 사용자로 로그인한 후에도 이 오류가 발생하면 관리자 사용자 권한이 정렬되지 않았기 때문일 수 있습니다. 마스터 사용자를 재설정하려면 AWS Management Console을 사용하세요. Amazon RDS for SQL Server의 마스터 사용자에 대한 db_owner 역할 멤버십 재설정을 참조하세요.
Access Denied 백업 또는 복원 프로세스가 백업 파일에 액세스할 수 없습니다. 이는 일반적으로 다음과 같은 문제로 인해 발생합니다. 잘못된 버킷을 참조하거나 잘못된 형식으로 버킷을 참조하거나 ARN을 사용하지 않고 파일 이름을 참조하는 경우. 버킷 파일의 권한이 잘못된 경우(예: 다른 계정이 만든 파일을 현재 액세스하려는 경우 올바른 권한을 추가). 잘못되었거나 불완전한 IAM 정책. IAM 역할에 올바른 버전을 포함한 필요한 모든 요소가 포함되어야 합니다. 이는 네이티브 백업 및 복원을 사용한 SQL Server 데이터베이스 가져오기 및 내보내기에서 강조됩니다.
BACKUP DATABASE WITH COMPRESSION은 <에디션_이름> 에디션에서 지원되지 않습니다. 백업 파일 압축은 Microsoft SQL Server Enterprise Edition 및 Standard Edition에서만 지원됩니다. 자세한 내용은 백업 파일 압축을 참조하세요.
키 이(가) 존재하지 않습니다. 암호화된 백업을 복원하려 했지만 유효한 암호화 키를 제공하지 않았습니다. 암호화 키를 확인하고 다시 시도하세요. 자세한 내용은 데이터베이스 복원을 참조하세요.
올바른 유형 및 덮어쓰기 속성으로 작업을 다시 실행하세요. 데이터베이스를 백업하려고 하면서 이미 존재하는 파일의 이름을 제공했지만 덮어쓰기 속성을 false로 설정하면 저장 작업이 실패합니다. 이 오류를 해결하려면 아직 존재하지 않는 파일 이름을 제공하거나 덮어쓰기 속성을 true로 설정하세요. 자세한 내용은 데이터베이스 백업을 참조하세요. 또한 데이터베이스를 복원하려고 했는데 실수로 rds_backup_database 저장 프로시저를 호출했을 수도 있습니다. 이 경우 rds_restore_database 저장 프로시저를 대신 호출하세요. 자세한 내용은 데이터베이스 복원을 참조하세요. 데이터베이스를 복원하려고 rds_restore_database 저장 프로시저를 호출했다면 유효한 백업 파일의 이름을 제공했는지 확인하세요. 자세한 내용은 네이티브 백업 및 복원 사용을 참조하세요.
RDS 인스턴스와 동일한 리전의 버킷을 지정하세요. Amazon RDS DB 인스턴스와 다른 AWS 리전의 Amazon S3 버킷으로 백업하거나 그 버킷에서 복원할 수 없습니다. Amazon S3 복제를 사용하여 백업 파일을 올바른 AWS 리전으로 복사할 수 있습니다. 자세한 내용은 Amazon S3 문서의 크로스 리전 복제를 참조하세요.
지정된 버킷이 존재하지 않습니다. 버킷과 파일에 대해 올바른 형식의 올바른 ARN을 제공했는지 확인합니다. 자세한 내용은 네이티브 백업 및 복원 사용을 참조하세요.
사용자 이(가) 리소스 에 대해 <kms 작업>을 수행할 권한이 없습니다. 암호화된 작업을 요청했지만 올바른 AWS KMS 권한을 제공하지 않았습니다. 올바른 권한이 있는지 확인하거나 권한을 추가하세요. 자세한 내용은 네이티브 백업 및 복원 설정을 참조하세요.
복원 작업이 10개 이상의 백업 파일에서 복원할 수 없습니다. 일치하는 파일 수를 줄이고 다시 시도하세요. 복원하려는 파일 수를 줄이세요. 필요한 경우 각 개별 파일을 더 크게 만들 수 있습니다.
'database_name' 데이터베이스가 이미 존재합니다. 대/소문자나 악센트만 다른 두 데이터베이스는 허용되지 않습니다. 다른 데이터베이스 이름을 선택하세요. 기존 데이터베이스와 이름이 같은 데이터베이스는 복원할 수 없습니다. 데이터베이스 이름은 고유합니다.

더 알아보기 (Learn more)