MySQL DB 인스턴스에 대한 연결 문제 해결
MySQL DB 인스턴스에 대한 연결 문제 해결
AWS RDS 사용자 가이드의 이 페이지를 한국어로 설명합니다.
출처: 문서
본문
새 DB 인스턴스에 대한 연결 실패의 일반적인 두 가지 원인은 다음과 같습니다.
- DB 인스턴스가 MySQL 애플리케이션 또는 유틸리티가 실행 중인 디바이스나 Amazon EC2 인스턴스의 연결을 허가하지 않는 보안 그룹으로 생성되었습니다. DB 인스턴스에는 연결을 허가하는 VPC 보안 그룹이 있어야 합니다. 자세한 내용은 Amazon VPC와 Amazon RDS를 참조하세요.
- 보안 그룹에서 인바운드 규칙을 추가하거나 편집할 수 있습니다. Source에서 My IP를 선택합니다. 이렇게 하면 브라우저에서 감지된 IP 주소에서 DB 인스턴스에 액세스할 수 있습니다.
- DB 인스턴스가 기본 포트 3306으로 생성되었고, 회사 네트워크의 디바이스에서 해당 포트로의 연결을 차단하는 회사 방화벽 규칙이 있습니다. 이 실패를 해결하려면 다른 포트로 인스턴스를 다시 생성하세요.
연결 문제에 대한 자세한 내용은 Amazon RDS DB 인스턴스에 연결할 수 없음을 참조하세요.