Amazon RDS for SQL Server 데이터베이스의 db_owner를 rdsa 계정으로 변경
Amazon RDS for SQL Server 데이터베이스의 db_owner를 rdsa 계정으로 변경
RDS for SQL Server DB 인스턴스에서 데이터베이스를 만들거나 복원할 때 Amazon RDS는 데이터베이스 소유자를 rdsa로 설정해요. SQL Server Database Mirroring(DBM) 또는 Always On 가용성 그룹(AG)을 사용하는 Multi-AZ 배포가 있다면, Amazon RDS는 보조 DB 인스턴스의 데이터베이스 소유자를 NT AUTHORITY\SYSTEM으로 설정합니다. 보조 데이터베이스의 소유자는 보조 DB 인스턴스가 기본 역할로 승격될 때까지 변경할 수 없어요. 대부분의 경우 데이터베이스 소유자를 NT AUTHORITY\SYSTEM으로 설정해도 쿼리를 실행할 때 문제가 되지 않지만, 실행에 높은 권한이 필요한 sys.sp_updatestats 같은 시스템 저장 프로시저를 실행할 때는 오류가 발생할 수 있습니다.
출처: 문서
본문
다음 쿼리를 사용하면 NT AUTHORITY\SYSTEM이 소유한 데이터베이스의 소유자를 확인할 수 있어요.