RDS for Db2 복제 문제 해결

RDS for Db2 복제 문제 해결

이 문서는 Amazon RDS 사용자 가이드의 Db2 관련 페이지를 한국어로 설명합니다.

출처: 문서

본문

이 주제에서는 일반적인 RDS for Db2 복제 문제를 설명하고 읽기 전용 복제본과 대기 복제본 모두에 대한 문제 해결 지침을 제공합니다. 다음 문제 해결 정보를 검토하는 것 외에도, Db2 복제본을 생성하기 전에 요구 사항 및 고려 사항을 충족하고 준비 단계를 완료했는지 확인하세요.

복제본 생성 실패

복제본 생성은 여러 가지 이유로 실패할 수 있습니다.

  • 비활성 데이터베이스(Inactive databases) – 복제본을 생성하기 전에 소스 DB 인스턴스의 모든 데이터베이스가 활성 상태여야 합니다.
    • 데이터베이스 활성화에 대한 정보는 RDS for Db2용 데이터베이스 저장 프로시저를 참조하세요.
  • 자동 백업 누락(Missing automatic backups) – 소스 DB 인스턴스에 자동 백업이 활성화되어 있어야 합니다.
    • 백업 활성화에 대한 정보는 RDS for Db2 복제본의 자동 백업 활성화하기를 참조하세요.
  • 파라미터 그룹 문제(Parameter group issues) – 복제본에는 사용자 지정 파라미터 그룹이 필요합니다. BYOL 라이선스의 경우 파라미터 그룹에 IBM 사이트 ID와 IBM 고객 ID가 포함되어야 합니다.
    • 자세한 내용은 Db2용 BYOL(Bring Your Own License)을 위한 IBM ID를 참조하세요.

Db2 복제 지연 모니터링

Amazon CloudWatch에서 복제 지연을 모니터링하려면 Amazon RDS ReplicaLag 지표를 확인하세요. 복제 지연 시간에 대한 자세한 내용은 읽기 복제 모니터링하기 및 Amazon RDS용 Amazon CloudWatch 지표를 참조하세요. 복제본 지연에 대한 CloudWatch 알람 설정에 대한 정보는 Amazon CloudWatch로 Amazon RDS 지표 모니터링하기를 참조하세요.

읽기 전용 복제본의 경우 지연 시간이 너무 길면 MON_GET_HADR 테이블을 쿼리하여 복제본 DB 인스턴스의 상태를 확인하세요.

대기 복제본의 경우 지연 시간이 너무 길면 MON_GET_HADR 테이블을 쿼리하여 소스 DB 인스턴스의 상태를 확인하세요. 복제본 DB 인스턴스는 사용자 연결을 수락하지 않으므로 복제본 DB 인스턴스를 쿼리하지 마세요.

높은 복제 지연의 일반적인 원인은 다음과 같습니다.

  • 복제본의 컴퓨팅 리소스 부족
  • 소스와 복제본 사이의 네트워크 연결 문제
  • 소스 데이터베이스의 높은 쓰기 활동
  • 복제본의 스토리지 성능 제한

높은 복제 지연이 지속되면 복제본 리소스 확장을 고려하세요. 자세한 내용은 Amazon RDS DB 인스턴스 수정하기를 참조하세요.

Db2 복제 오류

Db2 복제는 여러 이유로 오류 상태가 될 수 있습니다. 다음 작업을 수행하세요.

  • DB 인스턴스가 복제되고 있는지 확인하기 위해 이벤트와 DB 인스턴스 상태를 모니터링합니다.
    • 자세한 내용은 Amazon RDS 이벤트 알림 작업을 참조하세요.
  • Amazon RDS 콘솔에서 Db2 복제본의 진단 로그를 확인합니다. 로그에서 HADR 메시지의 오류를 찾아보세요. 로그 시퀀스 번호를 기본 시퀀스 번호와 비교하세요.
    • Db2 진단 로그 액세스 및 해석에 대한 정보는 Amazon RDS for Db2 데이터베이스 로그 파일을 참조하세요. Db2 HADR 구성 및 문제 해결에 대한 정보는 Amazon RDS for Db2 복제본 작업을 참조하세요.

복제 오류가 지속되면 복제본을 다시 생성해야 할 수 있습니다.

연결 문제

복제본에 연결할 수 없는 경우 복제본 모드에 대한 다음 정보를 검토하세요.

  • 대기 복제본(Standby replicas) – 설계상 사용자 연결을 수락하지 않습니다. 읽기 워크로드에는 읽기 전용 복제본을 사용하세요.
  • 읽기 전용 복제본(Read-only replicas) – 보안 그룹 설정, 네트워크 ACL, 파라미터 그룹 구성을 확인하세요.
    • 자세한 내용은 Amazon VPC 사용자 가이드의 보안 그룹을 사용하여 AWS 리소스에 대한 트래픽 제어하기, Amazon VPC 사용자 가이드의 네트워크 액세스 제어 목록으로 서브넷 트래픽 제어하기, Amazon RDS용 파라미터 그룹을 참조하세요.

성능 문제

복제본 성능이 좋지 않으면 다음 제안을 검토하세요.

  • 복제본에 적절한 컴퓨팅 및 스토리지 리소스가 있는지 확인합니다.
  • Amazon CloudWatch에서 ReplicaLag 지표를 모니터링합니다.
  • 복제본 DB 인스턴스 클래스를 확장하는 것을 고려합니다.

리소스 또는 인스턴스 클래스 수정에 대한 정보는 Amazon RDS DB 인스턴스 수정하기를 참조하세요.

복제 지연 모니터링에 대한 정보는 복제 지연 모니터링하기 및 Amazon RDS용 Amazon CloudWatch 지표를 참조하세요. 복제본 지연에 대한 CloudWatch 알람 설정에 대한 정보는 Amazon CloudWatch로 Amazon RDS 지표 모니터링하기를 참조하세요.

더 알아보기 (Learn more)