누락된 레코드로 인한 복제 실패 문제 해결

누락된 레코드로 인한 복제 실패 문제 해결

AWS RDS 사용자 가이드의 이 페이지를 한국어로 설명합니다.

출처: 문서

본문

Amazon RDS for MySQL 또는 MariaDB를 바이너리 로그 복제와 함께 사용할 때 읽기 복제본의 누락된 레코드로 인해 프로세스가 중단되는 복제 실패가 발생할 수 있습니다. 이 섹션에서는 이러한 문제를 진단하고 해결하는 방법을 설명합니다.

일반적인 원인

원본과 복제본 간의 데이터 불일치는 다음 시나리오 중 하나로 인해 발생할 수 있습니다.

  • 복제본의 수동 데이터 수정
  • sql_replica_skip_counter(MySQL 8.0.26 이전에는 sql_slave_skip_counter)를 사용하여 건너뛴 트랜잭션
  • 마이그레이션 도구를 사용한 초기 데이터 동기화 중 복제본의 누락된 행

문제 식별

이 문제의 일반적인 지표는 Can't find record 메시지와 함께 나타나는 오류 1032입니다. 다음 오류 메시지가 복제본의 오류 로그에 나타납니다.

더 알아보기 (Learn more)