s3_* 서버 설정
s3_* 서버 설정
이 설정들은 ClickHouse 서버가 S3 객체 스토리지와 연동할 때의 자격 증명(credentials) 처리, 리다이렉트, 재시도 정책을 제어해요. ClickHouse 소스 코드에서 자동으로 생성된 참조 문서예요.
출처: 문서
본문
이 설정들은 ClickHouse 서버를 구성하며 ClickHouse 소스 코드에서 자동으로 생성돼요.
s3_allow_server_credentials_for_system_table_disks
system 데이터베이스에 있는 테이블의 동적 disk(type = s3, ...)가 서버 자체(ambient) S3 자격 증명을 사용할 수 있게 허용해요. s3_allow_server_credentials_in_user_queries 제한에서 예외로 처리돼요. 서버 내부 인프라가 서버의 신원으로 시스템 테이블을 S3로 보내는(클라우드 운영자가 system 데이터베이스에 연결한) 경우를 위한 것이에요. 세션 설정과 달리 서버 수준 설정이므로, 서버 재시작 시 메타데이터에서 테이블을 다시 로드할 때도 예외가 적용돼요. 일반 사용자가 테이블을 만들 수 없는 system 데이터베이스로 범위가 제한되므로, 사용자 쿼리에 대한 제한을 완화하지는 않아요.
s3_credentials_provider_max_cache_size
캐시할 수 있는 S3 자격 증명 제공자(provider)의 최대 개수예요.
s3_load_table_anonymously_if_credentials_restricted
영구 S3 또는 S3Queue 테이블, 동적 disk(type = s3, ...), 또는 DataLakeCatalog(Glue, BigLake) 데이터베이스를 기존 메타데이터(서버 시작 또는 RESTORE)에서 로드할 때, 그 정의가 s3_allow_server_credentials_in_user_queries에 의해 사용자 쿼리에서 차단된 서버 자체(ambient) S3/클라우드 자격 증명을 해석할 경우 어떤 일이 일어날지 제어해요.
활성화되면(기본값), 시작을 중단하는 대신 객체가 해당 자격 증명 없이 로드돼요. S3/S3Queue 테이블 또는 동적 S3 디스크는 익명 S3 클라이언트로 구성되고, DataLakeCatalog 데이터베이스는 사용할 수 없는 카탈로그로 남아요. 서버는 시작되지만, 해당 객체는 자격 증명이 다시 허용된 출처로 해석될 때까지 접근할 수 없어요(프라이빗 버킷 요청은 거부되고, 카탈로그는 명확한 오류를 보고해요). 서버의 신원을 조용히 되찾지는 않아요. 이렇게 하면 제한이 생기기 전의 구버전에서 만든 객체나, 나중에 명명된 컬렉션이 use_environment_credentials = 1로 다시 바인딩된 객체 하나 때문에 서버 시작이 중단되는 일을 막아줘요.
비활성화하면, 그런 객체의 로드가 실패하여 서버가 시작되지 않을 수 있어요. 조용히 접근할 수 없는 테이블·디스크·카탈로그 데이터베이스보다 강한 실패를 원할 때만 사용해요.
s3_max_redirects
허용되는 S3 리다이렉트 홉(hop)의 최대 수예요.
s3_retry_attempts
Aws::Client::RetryStrategy를 위한 설정이에요. Aws::Client가 스스로 재시도하며, 0이면 재시도하지 않아요.