일반적인 연결 문제와 해결 방법
일반적인 연결 문제와 해결 방법
이 항목은 일반적인 오류 메시지의 근본 원인일 가능성이 높은 연결 문제를 해결하는 단계를 설명해요.
본문
방화벽 또는 프록시 SSL 검사 문제
Snowflake는 자사 서비스의 TLS/SSL 인증서 변경 또는 수정을 지원하지 않아요. 네트워크 관리자와 협력하여 URL 허용 기능이 반환하는 모든 서비스 엔드포인트가 네트워크를 통해 완전한 패스스루(passthrough) 접근 권한을 갖도록 하세요. 네트워크 환경의 보안에 특별한 요구 사항이 있어 이 주제에 대해 추가 논의가 필요하다면 계정 팀에 문의하세요.
OCSP 및 포트 80 문제
Snowflake와의 모든 통신은 포트 443을 사용해요. 그러나 OCSP 인증서 확인(check)은 포트 80을 통해 전송돼요. 네트워크에서 포트 80이 열려 있지 않으면 OCSP 관련 문제가 발생할 수 있으며, 이때는 OCSP를 언급하는 오류(예: JDBC 오류 5)가 함께 나타날 수 있어요. 이러한 시나리오에서는 조직의 시스템 또는 네트워크 관리자가 방화벽의 포트 443과 80 트래픽을 열고, Snowflake 허용 목록의 모든 URL을 허용하도록 해야 해요.
참고
암호화되지 않은 HTTP로 전송되는 고객 데이터는 없어요. 전송되는 것은 OCSP 작업과 관련된 데이터뿐이에요. 또한 Snowflake는 OCSP 응답기(Responders)를 제공하거나 유지하지 않는다는 점을 기억하세요. OCSP 캐시 서버(Cache Server)는 예외이며 Snowflake가 제공하고 운영해요.
포트 80을 활성화한 후에도 문제가 지속되면 운영 체제에 따라 OCSP 관련 임시 캐시 파일을 모두 삭제하고 연결을 다시 시도해 보세요.
- Windows:
${HOME}/AppData/Local/Snowflake/Caches - macOS:
${HOME}/Library/Caches/Snowflake - Linux:
${HOME}/.cache/snowflake
대용량 쿼리 결과 집합 가져오기 실패
때때로 클라이언트는 작은 쿼리 결과는 가져올 수 있지만 큰 결과 집합은 가져오는 데 어려움을 겪을 수 있어요. 큰 결과(100KB 초과)를 가져오려면 클라이언트가 모든 스테이지(STAGE) 엔드포인트에 대해 인증서 패스스루가 포함된 완전한 네트워크 접근 권한을 가져야 하기 때문이에요. 이 문제는 프록시나 방화벽의 Snowflake 허용 목록에서 URL 허용을 하면 자주 해결할 수 있어요.
DNS 구성 문제
Private Connectivity 시나리오에서는 호스트 또는 원격 DNS 서버에서 DNS 관련 설정이 잘못 구성될 수 있어요. 이러한 문제는 일반적으로 "Name or service not known" 또는 "nodename nor servname provided, or not known"과 같은 오류 메시지와 함께 나타나요(예: JDBC 오류 2). AWS PrivateLink, Azure Private Link, 또는 Google Cloud Private Service Connect를 구성하는 경우 네트워크 관리자는 연결 URL에 대한 DNS 레코드를 생성하고 관리해야 해요. 공급자와 관련된 모든 구성 단계를 올바르게 수행했는지 확인하세요.
일시적인 네트워크 문제
때때로 문제는 일시적일 수 있어요. 이는 OCSP 서버, 원격 DNS 서버, Snowflake 서버가 일시적으로 사용할 수 없거나, 클라이언트가 일시적으로 해당 서버에 도달하지 못하는 상황에서 발생할 수 있어요.
추가 문제 해결
문제가 일시적이지 않거나 위 단계로 문제가 해결되지 않으면 문제 해결 단계의 단계를 따르세요.